quinta-feira, 14 de setembro de 2017

CSU Trabalhe conosco

http://www.csu.com.br/TrabalheConosco.aspx

Secretaria abre seleção para contratação temporária de profissionais

Secretaria abre seleção para contratação temporária de profissionais

Interessados devem se inscrever até o dia 28 de setembro



Assessoria de Imprensa - 14/09/2017 11:55h



Estão abertas as inscrições para Seleção Simplificada que irá contratar temporariamente profissionais de nível Médio e Superior para o preenchimento de 75 vagas no âmbito da Secretaria de Educação do Estado (SEE). Os profissionais deverão atuar no Programa Nacional de Acesso ao Ensino Técnico e Emprego (Pronatec), realizado nas Escolas Técnicas Estaduais. A inscrição é gratuita e deve ser feita até o dia 28 de setembro.
As vagas são de Professor de Educação Profissional e Assistente Administrativo de Nível Médio e Superior, com lotação em todas as regiões do Estado e os salários chegam até R$ 2.932. A seleção será realizada através da avaliação da experiência e de títulos, com resultado divulgado no dia 11 de outubro. O contrato é válido por um ano e pode ser prorrogado por igual período até o máximo de seis anos, a partir da data de homologação do seu Resultado Final.
O candidato deve ter idade mínima de 18 anos, ser brasileiro, estar em dia com as obrigações eleitorais, ter disponibilidade para viajar e não acumular funções dentro da esfera de Governo ou qualquer Poder, dentre outros requisitos que devem ser verificados no edital. A inscrição deve ser feita através de preenchimento de formulário eletrônico e tabela de pontuação de análise de experiência profissional e de títulos, de acordo com a função para a qual concorre.
Confira o Edital


Faça aqui sua inscrição

Eu tenho a marca da promessa

ESTÁTUA PENSADORA



segunda-feira, 11 de setembro de 2017

Planilha de estudos para organizar o tempo irregular




A ideia é a seguinte você pode usar no computador ou imprimir, coloque todos os materiais que você deseja estudar, e cada assunto você vai marcando um x no quadrado.



Esse mundo tá ficando chato

Esse mundo tá ficando chato, não se pode mais tocar nada, não se pode mais divulgar nada, tudo é censurado. Eita direitos autorais triste.... Até a música do parabéns pra você foi comprada.

Estátua pensadora - Agora vai

Agora vai, prá onde não sei.

sábado, 9 de setembro de 2017

Davi Sacer - O Que Dizer

O que dizer?

O que dizer?

O que dizer para pessoas que estão sem esperança? Que até choram? Nada se produz, nada de novo de baixo do sol. Será que só nos resta chorar e definhar? Será que não existe esperança? Estive lendo esta semana Eclesiastes, o homem é um eterno questionador. Questiona sobre tudo e sobre todos. Até rimos e fazemos piadas de algumas coisas. Mas parece que nosso riso é falso. Ou então as piadas não são tão engraçadas assim ou até mesmo piadas com a própria desgraça. Não adianta discutir, não adianta achar que tudo vai melhorar de uma hora pra outra. Não adianta achar que vai haver um salvador da pátria que enfim resolva tudo. O que estamos vivendo é um momento ímpar onde muito foi roubado.
Brincava hoje aqui em casa dizendo que a operação Lava Jato vai terminar em D. Pedro. Sonhos perdidos, é tudo vaidade. Promessas de salário mínimo regidas na carteira, muito belas, mas de fato o salário de 900 e poucos reais não irá suprir todas as nossas necessidades. Pesquisas revelam que o salário deveria ser 3.000 reais para suprir as necessidade que há em nossa legislação. Salário que é um sonho de consumo para muitos.
Aliás, muitos ainda vivem abaixo da linha de pobreza e a desigualdade social e a distribuição de renda é muito defasada. O que dizer então? O que dizer todos já sabem. O que fazer é a questão. O que fazer? Manter o foco, mesmo em meio à dor, mesmo em meio à aflição.
Enquanto o emprego não vem, estude, procure fazer um curso, existem vários gratuitos. A internet tem muito lixo, mas também tem muita coisa boa. Enfim manter a esperança e o bom ânimo são fundamentais, além de cuidar da saúde física e mental.

quinta-feira, 7 de setembro de 2017

Compreensão e Interpretação de textos

Compreensão: apreensão das informações contidas no texto.

Interpretar: utilizar a experiência de leitor para entender as mensagens deixadas no texto pelo autor:
-Subjetivas: as informações contidas no texto são apenas um ponto de partida par suas divagações.
-Objetiva: Leva em conta as marcas significativas contidas no texto.


Tipologia Textual

Descrição
Objetiva: busca a precisão informativa.
Subjetiva: procura mostrar aquilo que pensamos acerca do objeto.

Narração: apresenta fatos vividos por personagens.

Dissertação: Exposição de uma ideia.

Funções da Linguagem

Função referencial (ou denotativa)
Transmite uma informação objetiva, expões dados da realidade de modo objetivo, não faz comentários, nem avaliação.

Função emotiva: o objetivo do emissor é transmitir suas emoções e anseios.

Função conativa ou apelativa: O objetivo é  influenciar, convencer o receptor de alguma coisa por meio de uma ordem.

Função Metalinguística: ocorre quando o emissor explica um código usando o próprio código.

Função fática: verificar se a mensagem está sendo transmitida ou para dilatar a conversa.

Função poética: O objetivo do emissor é expressar seus sentimentos.

FUNÇÕES DA LINGUAGEM

FUNÇÕES DA LINGUAGEM:

  • Emissor: quem emite a mensagem.
  • Receptor: quem recebe a mensagem.
  • Mensagem: Informação transmitida.
  • Referente: a situação com que se relaciona a mensagem.
  • Canal: meio de comunicação utilizado para envio da mensagem
  • Código: sistema utilizado para o envio da mensagem.

Níveis de Linguagem

Níveis de linguagem

  • Nível culto ou formal: é a língua oficial, usada sobretudo na escrita.
  • Nível coloquial (popular, informal): é a língua do dia a dia.
  • Regionalismo: é a língua utilizada em determinada regiões.
  • Gíria: Linguagem grupal, própria de cada grupo social.
  • Jargão: linguagem técnica.

sexta-feira, 1 de setembro de 2017

Estátua Pensadora


Minha vida anda muito parada. Deve ser porque ainda sou uma Estátua.

sábado, 26 de agosto de 2017

Por quê tão sério?

Quando fazemos uma retrospectiva da nossa vida, vemos que sorrir é bem melhor que chorar. Elogiar é melhor que criticar. Muitas vezes deixamos que os problemas nos sufoquem, então deixarmos morrer a criança que existe dentro de nós; a nossa essência. Então começamos a reclamar, reclamar e nos tornamos como dizia um livro que li, uma pessoa rabugenta.

Aí eu pegunto, será que não deveríamos rir mais? Será que não deveríamos cantar mais, mesmo em meio à tristeza? Creio que sim. É como o filme infantil Monstros S/A, o sorriso tinha mais poder que o choro das crianças. Até que faz sentindo, então surra mais, rsrsrsrs, ria mais, faz bem pra o coração.

Uma palavra de ânimo

Neste exato momento estou ouvindo a Banda Catedral acústico, uma música tranquila, meu dia foi bom passeei, enfim renovei as minhas forças. Quando deixamos que o desânimo tomar conta de nossas vidas ele realmente toma conta.

Mas se nos enchermos de ânimo e nossa alma de tranquilidade, não nos deixamos abater pelos problemas da vida. Muitas vezes nos surpreendemos pois sozinhos somos fracos, mas juntos somos mais.

Se está difícil cante, ame o seu próximo, este é o sentido. O dinheiro não vai cair do céu. Deus deu inteligência para o homem, inclusive para vencer às adversidades. Por exemplo, qual animal que tem a capacidade de se adaptar a qualquer ambiente seja frio ou quente?

As oportunidades virão, mas devemos está preparados para elas. A crise chegou, faça cursos, escreva, monte um blog, procure busque que um dia a pedra cai na cabeça e Deus muda a situação.

sexta-feira, 25 de agosto de 2017

Exemplo de Procedimento Visual G

algoritmo "Detectordepesado"
var
cont: inteiro
nome, pesado: caractere
peso, maior: real

procedimento topo()
inicio
limpatela
escreval("--------------------------------")
escreval(" D E T E C T O R DE P E S A D O ")
escreval("Maior Peso ate agora: ", maior, "Kg")
escreval("--------------------------------")
fimprocedimento

inicio
   topo()//Procedimento
   para cont de 1 ate 5 faca
     escreva("Digite o nome: ")
     leia(nome)
     escreva("Digite o peso de ", nome, ": ")
     leia(peso)
     se (peso>maior) entao
        maior:=peso
        pesado:=nome
     fimse
     topo()//Procedimento
fimpara
limpatela
topo()//Procedimento
escreval("A pessoa mais pesada foi ", pesado, " com ", maior, " kg")

fimalgoritmo

quarta-feira, 23 de agosto de 2017

Protesto no Terminal do Barro







Comentário do dia

Boa noite, Recentemente estou cursando Desenvolvimento de Sistemas na Escola Técnica Estadual Miguel Batista. Acabei perdendo um oportunidade estagiar por conta da escola só permitir a partir do 2º semestre. Graças a Deus as coisas tem melhorado, mas às vezes questiono certos tipos de restrições impostas pelas escolas, na verdade não considero justas, creio que deveria ser analisado caso a caso, afinal já tenho uma boa experiência na área de informática, e um estágio só faria aperfeiçoar.

domingo, 13 de agosto de 2017

10 DICAS DE SER UM FRACASSADO

As dicas abaixo servem para ajudar as pessoas a entenderem o que faz de alguém um FRACASSADO. Se você quer se tornar um, deve apenas segui-las cuidadosamente. Não deixe de aplicar nenhuma!
Dica 1:  Escute conselhos e palpites de pessoas que não tem sucesso e aplique tudo na sua vida. Se o objetivo é serum fracassado porque escutar pessoas bem sucedidas?
Dica 2:  Simplesmente sente-se e relaxe. Planejamento é para vencedores, mas você não quer se tornar um. Olhe para todas as pessoas de sucesso, como elas trabalham duro para ter o que querem e não descansam até terem. Você quer ser como elas? Claro que não! Fique frio. Relaxe. Evite fazer qualquer esforço e planejamento pois, além de garantir que você continue sendo umfracassado, ajuda você a não se cansar nem planejar.
Dica 3: Grude seus olhos na tevê. O que seria dos fracassados se não fossem os “preguiçosos do sofá”? Não há melhor maneira de praticar a dica 2. Estas coisas vão lhe completar com boas doses de nada e assegurar que você nunca tenha tempo de fazer algo aproveitável .
Dica 4: Nunca termine o que começou. O perigo de chegar ao final de algo que você tenha começado é que você, provavelmente, alcançará o sucesso. Certifique-se de nunca fazer isso. O ideal é que você chegue próximo ao final e depois desista. A sensação deser um fracassado vai realmente aumentar.
Dica 5: Orgulhe-se de si mesmo. Sempre reconheça que você sabe tudo e não precisa de ninguém para te ensinar qualquer coisa. Desconfie de tudo e de todos.
Dica 6: Simplesmente viva dia após dia. Para ter certeza de que você continuará sendo umfracassado, nunca faça metas para o futuro . Não se preocupe em atingir metas (Para quê? Você é umfracassado!)
Dica 7: Ter tempo livre com dinheiro sobrando não são coisas que fracassados tem, por isso procure imediatamente rejeitar qualquer proposta tentadora que lhe ofereça estes benefícios. E não se esqueça de sempre trabalhar pelo dinheiro e jamais fazer o dinheiro trabalhar para você, isso garantira que você morra trabalhando.
Dica 8Habitue-se a sempre ter desculpas para suas falhas. Culpe seus parentes, seu chefe, a empresa, Deus, o diabo, ou até mesmo seu cachorro. Nunca se responsabilize por seus atos. O que quer que aconteça de mal a você, nunca é sua culpa. Queixe-se muito, reclame, chore e não se esqueça de ser muito pessimista (marca maior dos fracassados).
Dica 9Perca seus sonhos. Os sonhos são os piores inimigos do fracassado. É a única coisa que pode realmente mudar sua vida. Perca-os e terá a certeza de permanecercomo fracassado anos a fio.
Dica 10:  Não tome decisões. Simplesmente siga o fluxo do que quer que a vida lhe traga. Saiba que todos os problemas a sua volta são muito maiores que você, então, não perca energia tentando mandá-los embora. Seja indeciso e seu status defracassado será gravado numa pedra.

Autor desconhecido.

Esperei com paciência no Senhor

Uma das coisas mais fáceis que existem é aconselhar os outros, mas dar conselhos para si mesmo é uma das coisas mais difíceis que existem. É fácil dizer: tenha ânimo, é fácil dizer, tenha paciência, mas vivenciar certas situações em nossas vidas quando o problema persiste por anos não é algo fácil. É fácil dizer, eu tenho a fé de Abraão, mas até mesmo este vacilou, é fácil dizer tenha a paciência de Jó, mas de todas a mais importante é ter fé, ter fé, esperança que essa crise vai passar, afinal:

Esperei com paciência no SENHOR, e ele se inclinou para mim, e ouviu o meu clamor
Salmos 40:1

domingo, 6 de agosto de 2017

Frase do dia

Nem sempre é fácil tomar as decisões certas. Mas ser fiel a sua consciência é o melhor caminho.

sexta-feira, 21 de julho de 2017

Tecnologia HDMI

Recentemente fizemos um trabalho na Igreja Batista na Av. Liberdade, a troca do cabo do data show de um vga para um HDMI, fiquei impressionado com os resultados. Creio que esta tecnologia de vídeo foi bem sucedida. Além de transmitir vídeos de alta qualidade, também transmite áudio.

quinta-feira, 20 de julho de 2017

Dica do dia

Dica do dia: maior parte dos problemas de informática está entre o monitor e a cadeira.

sexta-feira, 7 de julho de 2017

Frase do dia

Deus não é obrigado a atender nossos caprichos. Ele o faz se o mesmo quiser por sua infinita graça.

sábado, 1 de julho de 2017

Script de CEP VIA SQL


https://www.youtube.com/watch?v=r-DJ9U7ZAnE


SELECT DISTINCT
logradouros.ds_logradouro_nome,
logradouros.no_logradouro_cep,
bairros.ds_bairro_nome,
cidades.ds_cidade_nome,
uf.ds_uf_sigla
FROM logradouros, bairros, cidades, uf
WHERE logradouros.no_logradouro_cep IN ('77458000') AND bairros.cd_bairro = logradouros.cd_bairro_log AND cidades.cd_cidade = bairros.cd_cidade_bar AND uf.cd_uf= cidades.cd_uf_cid;



quinta-feira, 29 de junho de 2017

Pensamento do dia

É engraçado como somos tão hábeis em criticar, em brigar, mas em conciliar somos tão frágeis. É fácil criticar seu próximo, sua opinião. Mas a Bíblia fala que até um tolo quando se cala se passa por sábio. Já critiquei muito no passado. Hoje em dia respeito a opinião alheia, mesmo que muitas vezes não receba isso em troca. Enfim, hoje em dia procuro ser mais produtivo e focar em coisas mais concretas. Afinal, ajudar é bom, ser produtivo melhor ainda.

terça-feira, 13 de junho de 2017

Frase do dia 2

E quanto tudo se acabar, ainda restará o louvor...

Frase do dia

Podemos até perder alguns bytes, mas nossa essência sempre permanecerá...

Opiniao - Cursos Técnicos

Terminei um curso superior e agora estou fazendo um curso técnico de Desenvolvimento de Sistemas. Tenho percebido a diferença. No curso técnico você realmente tem que saber executar as tarefas, no curso superior é muita teoria, o curso técnico é mais prático. E haja esquentar os miolos... rsrsrsr

Posicionamento - Quadrado - Lógica de programação

28 - Imagine que exista um comando chamado "posiciona (x,y)" em alguma linguagem de programação. Onde o X representaria a coluna que algo deve ser impresso na tela, e Y a linha que algo deve ser impresso na tela. Desta forma, o algoritmo abaixo:
início
 posiciona (10,2)
 escrever ‘Olá’
fim

Escreveria a palavra ‘Olá’ na segunda linha da tela, a partir da 10 coluna. Baseado nesta situação, escreva um algoritmo, utilizando este comando 'posiciona' citado, que desenhe na tela um retângulo de 60 colunas (a partir da coluna 1 da tela) e 10 linhas (a partir da linha 1 da tela), sendo que a borda deste retângulo será formada pelo caractere ‘+’. Lembre que somente a primeira e última linha deverão ter todas as colunas preenchidas com o caractere ‘+’. As demais linhas (entre 2 e 9) só terão as colunas 1 e 60 preenchidas. A aparência deste retângulo deve ser parecida com a figura abaixo: 

+++++++++++++++++++++++++++++++++++++++++
+ +
+ +
+ +
+ +
+ +
+ +
+ +
+++++++++++++++++++++++++++++++++++++++++

==============================================================

Algoritmo "Quadrado_ola"
// Disciplina   : [Linguagem e Lógica de Programação]
// Autor(a)    : Daniel Alves Barbosa
// Data atual  : 12/06/2017
Var
   // Seção de Declarações das variáveis
   coluna, linha, contador, bug3: inteiro
   mais, bug2: caractere
   posicionacol, posicionaln, posicionacol2, posicionacol3: inteiro

Inicio
   // Seção de Comandos, procedimento, funções, operadores, etc...
   mais := "+"

   repita
      escreval ("Digite a coluna  entre 2 de 59")
      leia (posicionacol)
   ate ((posicionacol>=2) e (posicionacol<=59))


   repita
      escreval ("Digite a linha entre 2 e 9")
      leia (posicionaln)
   ate ((posicionaln>=2) e (posicionaln<=9))

   //bug do 2
   se(posicionacol=2) entao
      posicionacol2:=posicionacol+1
      bug3:=1
      bug2:=""
   senao
      posicionacol2:=posicionacol-1
      bug3:=2
      bug2:=" "
   fimse
   //bug do 2

   posicionacol3:=posicionacol+3



   para linha de 1 ate 10 passo 1 faca
      //se b determinei a 1ª e 10ª linha com mais
      se ((linha=1) ou (linha=10)) entao

         para coluna de 1 ate 60 passo 1 faca
            escreva(mais)
            se (coluna = 60) entao
               escreval(" ")
            fimse
         fimpara
      senao
         //Determinei a linha que vai receber o ola
         se (linha=posicionaln) entao
            escreva (mais)
            para contador de bug3 ate posicionacol2 faca

               escreva (bug2)
               se (contador = posicionacol2) entao
                  escreva ("Ola")
                  para contador de posicionacol3 ate 59 faca
                     escreva (" ")
                     se (contador=59) entao
                        escreva (mais)
                     fimse
                  fimpara
               fimse
            fimpara

            escreval (" ")
         fimse
         //Linhas em branco
         se ((linha<>1) e (linha<>10) e (linha <> posicionaln)) entao
            para contador de 1 ate 60 faca
               se (contador=1) ou (contador=60) entao
                  escreva (mais)
               senao
                  escreva (" ")
               fimse
            fimpara
            escreval (" ")
         fimse
         //fim ultimo se
      fimse
   fimpara



Fimalgoritmo




terça-feira, 6 de junho de 2017

Divisão Algoritmo - Enquanto




algoritmo "divisao_enquanto"
// Função :
// Autor :
// Data : 31/05/2017
// Seção de Declarações
//04 - Escreva um algoritmo para ler 2 valores e se o segundo valor informado for ZERO,
//deve ser lido um novo valor, ou seja, para o segundo valor não pode ser aceito o valor
//zero e imprimir o resultado da divisão do primeiro valor lido pelo segundo valor lido.
//(utilizar a estrutura REPITA).
//05 - Reescreva o exercício anterior [04] utilizando a estrutura ENQUANTO.


var
num1, num2, divisao: real

inicio
// Seção de Comandos
  escreval("Este programa divide dois números")
  escreval("Digite o primeiro número")
  leia (num1)

     enquanto (num2=0) faca
        escreval ("Digite o segundo número")
         leia(num2)
         se(num2<>0) entao
           divisao:= num1/num2
         senao
           escreval("Não existe divisão por zero")
         fimse
    fimenquanto
    
    escreval("O resultado da divisão é ", divisao)
         

fimalgoritmo

Dividir dois números lógica de programação

04 - Escreva um algoritmo para ler 2 valores e se o segundo valor informado for ZERO, deve ser lido um novo valor, ou seja, para o segundo valor não pode ser aceito o valor zero e imprimir o resultado da divisão do primeiro valor lido pelo segundo valor lido. (utilizar a estrutura REPITA).


algoritmo "divisao"
// Função :
// Autor :
// Data : 31/05/2017
// Seção de Declarações

var
num1, num2, divisao: real

inicio
// Seção de Comandos
  escreval("Este programa divide dois números")
  escreval("Digite o primeiro número")
  leia (num1)
    repita
        escreval ("Digite o segundo número")
         leia(num2)
         se(num2<>0) entao
           divisao:= num1/num2
         senao
           escreval("Não existe divisão por zero")
         fimse
    ate(num2<>0)
    escreval("O resultado da divisão é ", divisao)
         

fimalgoritmo

Contar números pares de 1 a 100 algoritmo

algoritmo "cont_par100"
// Função :
// Autor :
// Data : 05/06/2017
// Seção de Declarações 
var
contador, soma: inteiro

inicio
// Seção de Comandos
  para contador de 1 ate 100 passo 1 faca
     se(contador mod 2 = 0) entao
     escreval (contador)
     soma := soma + contador
     fimse
  fimpara
  escreval ("A soma é ", soma)

fimalgoritmo

Cálculo de aposentadoria - Algoritmo

03 -  Uma empresa quer verificar se um empregado está qualificado para a aposentadoria ou não. Para estar em condições, um dos seguintes requisitos deve ser satisfeito:

 - Ter no mínimo 65 anos de idade.
 - Ter trabalhado no mínimo 30 anos.
 - Ter no mínimo 60 anos e ter trabalhado no mínimo 25 anos.


Com base nas informações acima, faça um algoritmo que leia: o número do empregado (código), o ano de seu nascimento e o ano de seu ingresso na empresa. O programa deverá escrever a idade e o tempo de trabalho do empregado e a mensagem 'Requerer aposentadoria' ou 'Não requerer'.

algoritmo "aposentadoria"
// Função :
// Autor :
// Data : 31/05/2017
// Seção de Declarações 

var
numero_do_empregado, ano_de_nascimento, ano_atual, ano_de_ingresso_na_empresa: inteiro
idade, tempo_de_trabalho: inteiro
tempo_que_falta: inteiro
inicio

//Ano atual
  ano_atual := 2017

// Seção de Comandos
//Entrada de dados
  escreval ("Este programa verifica o cálculo da aposentadoria")
  escreval ("-------------------------------------------------")
  escreval ("Digite o número do empregado")
  leia (numero_do_empregado)
  escreval ("Digite o ano do nascimento do empregado")
  leia (ano_de_nascimento)
  escreval ("Digite o ano de ingresso na empresa")
  leia (ano_de_ingresso_na_empresa)
//Cálculo da idade
  idade:= ano_atual - ano_de_nascimento
 //Cáculo do tempo de servico
  tempo_de_trabalho:= ano_atual - ano_de_ingresso_na_empresa
     //Condições
     se ((idade>=65) ou ((idade>=60) e (tempo_de_trabalho >=25)) ou (tempo_de_trabalho>=30)) entao
         escreval("Requerer aposentadoria")
     senao
         escreval ("Não requerer aposentadoria")
     fimse
     escreval("A idade do empregado é ", idade)
     escreval("O tempo de trabalho do emprego é ", tempo_de_trabalho)
     
     se((idade>=60) e (tempo_de_trabalho<=25)) entao
       tempo_que_falta:=25-tempo_de_trabalho
     senao
       tempo_que_falta:=30-tempo_de_trabalho
         se(tempo_que_falta<0) entao
         escreval ("O tempo que falta para se aposentar é 0 anos")
         senao
            escreval("O tempo que falta para se aposentar é: ", tempo_que_falta ," anos")
         fimse
     fimse




fimalgoritmo

Frutaria - Algoritmo

02 -  Uma fruteira está vendendo frutas com a seguinte tabela de preços:
            Até 5 Kg            Acima de 5 Kg
Morango   R$ 2,50 por Kg        R$ 2,20 por Kg
Maçã      R$ 1,80 por Kg        R$ 1,50 por Kg

Se o cliente comprar mais de 8 Kg em frutas ou o valor total da compra ultrapassar R$ 25,00, receberá ainda um desconto de 10% sobre este total. Escreva um algoritmo para ler a quantidade (em Kg) de morangos e a quantidade (em Kg) de maças adquiridas e escreva o valor a ser pago pelo cliente.

 algoritmo "frutaria06062017"
// Função :
// Autor :
// Data : 06/06/2017
// Seção de Declarações 
var
   mor_peso, maca_peso: real
   mor_preco, maca_preco: real
   frutas_pct, frutas_pst: real


inicio
// Seção de Comandos
   escreval ("Este programa calcula o preco em uma frutaria")
   escreval ("Digite o peso do morango")
   leia (mor_peso)
   escreval ("Digite o peso da macã")
   leia (maca_peso)
   
   frutas_pst:= mor_peso + maca_peso
   
   se (frutas_pst<=5 ) entao
      mor_preco:=2.50*mor_peso
      maca_preco:=1.8*maca_peso
   senao
      mor_preco:= 2.20*mor_peso
      maca_preco:= 1.50*maca_peso
   fimse
   frutas_pct:= mor_preco+maca_preco
   
   se ((frutas_pst>8) ou (frutas_pct>25)) entao
      frutas_pct:= frutas_pct*0.9
   senao
      frutas_pct:= frutas_pct*1
   fimse
   
   escreval ("O preço a ser pago é: ", frutas_pct)
   
fimalgoritmo

Idade homem mulher - algoritmo - visual g

01 - Escreva um algoritmo que leia as idades de 2 homens e de 2 mulheres (considere que as idades dos homens serão sempre diferentes entre si, bem como as das mulheres). Calcule e escreva a soma das idades do homem mais velho com a mulher mais nova, e o produto das idades do homem mais novo com a mulher mais velha.


algoritmo "idade_homem_mulher06032017"
// Função :
// Autor :
// Data : 06/06/2017
// Seção de Declarações 
var
somahv_mn, prod_hn_mv, mulher1, mulher2, homem1, homem2: inteiro
mulhern, mulherv, homemn, homemv: inteiro
inicio
// Seção de Comandos
   escreval ("Este programa compara a idade entre 4 pessoas")
   escreval ("Digite a idade da 1ª mulher")
   leia(mulher1)
   escreval ("Digite a idade da 2ª mulher")
   leia(mulher2)
   escreval ("Digite a idade do 1º homem")
   leia (homem1)
   escreval ("Digite a idade do 2º homem")
   leia (homem2)
   
   se (mulher1 < mulher2) entao
       mulhern:=mulher1
       mulherv:=mulher2
   senao
        mulherv:= mulher1
        mulhern:= mulher2
   fimse
   
   se (homem1< homem2) entao
       homemn:= homem1
       homemv:= homem2
   senao
       homemv:= homem1
       homemn:= homem2
   fimse
   
   somahv_mn:= homemv+ mulhern
   prod_hn_mv:= homemn*mulherv
   
   escreval ("A soma das idadades do homem mais novo com a mulher mais nova é ")
   escreval (somahv_mn)
   escreval ("O produto das idades do homem mais novo com a mulher mais velha é ")
   escreval (prod_hn_mv)


fimalgoritmo