domingo, 14 de maio de 2017

Exemplo Visual G - Validar Dois Números E dizer qual é o maior

Algoritmo "numeros iguais"
// Disciplina  :  [Linguagem e Lógica de Programação] 
// Professor   : Antonio Carlos Nicolodi 
// Descrição   : Aqui você descreve o que o programa faz! (função)
// Autor(a)    : Nome do(a) aluno(a)
// Data atual  : 14/05/2017
Var
// Seção de Declarações das variáveis 
   num1, num2: inteiro

Inicio
// Seção de Comandos, procedimento, funções, operadores, etc... 
   escreval("Este programa ler dois numeros diferentes e verifica o maior")
   repita
         escreval ("Digite dois números diferentes")
         escreval("Digite o primeiro número")
         leia(num1)
         escreval("Digite o segundo número")
         leia (num2)
   ate(num1<>num2)
   se (num1>num2) entao
      escreval ("O 1ºnº", num1, " é  maior e o 2ºnº", num2 ," é o menor")
   senao
      escreval ("O 2ºnº", num2 ," é maior e o 1ºnº", num1 ," é o menor")
   fimse
   


Fimalgoritmo

segunda-feira, 1 de maio de 2017

Código Java - Cadastro de Usuário - Exemplo

//package source;
import java.io.Console;

public class Ola{
public static void main(String[] args){

Console cnsl = System.console();

String nome = cnsl.readLine("Cadastre uma Usuario: ");

char [] senha = cnsl.readPassword("Cadastre uma senha: ");
String senha3 = String.valueOf(senha);

String nome2 = cnsl.readLine("Entre com seu usuario: ");
 
char[] senha2 = cnsl.readPassword("Entre com sua senha");
String senha4 = String.valueOf(senha2);
 
if((nome.equals(nome2)) & (senha3.equals(senha4))){
System.out.println("Usuario Cadastrado com sucesso: ");
System.out.println("Usuario: " + nome);
System.out.println("Senha: " + senha3);
}
else {
System.out.println("Usuario nao cadastrado ");

   }
}
}