quinta-feira, 29 de junho de 2017

Pensamento do dia

É engraçado como somos tão hábeis em criticar, em brigar, mas em conciliar somos tão frágeis. É fácil criticar seu próximo, sua opinião. Mas a Bíblia fala que até um tolo quando se cala se passa por sábio. Já critiquei muito no passado. Hoje em dia respeito a opinião alheia, mesmo que muitas vezes não receba isso em troca. Enfim, hoje em dia procuro ser mais produtivo e focar em coisas mais concretas. Afinal, ajudar é bom, ser produtivo melhor ainda.

terça-feira, 13 de junho de 2017

Frase do dia 2

E quanto tudo se acabar, ainda restará o louvor...

Frase do dia

Podemos até perder alguns bytes, mas nossa essência sempre permanecerá...

Opiniao - Cursos Técnicos

Terminei um curso superior e agora estou fazendo um curso técnico de Desenvolvimento de Sistemas. Tenho percebido a diferença. No curso técnico você realmente tem que saber executar as tarefas, no curso superior é muita teoria, o curso técnico é mais prático. E haja esquentar os miolos... rsrsrsr

Posicionamento - Quadrado - Lógica de programação

28 - Imagine que exista um comando chamado "posiciona (x,y)" em alguma linguagem de programação. Onde o X representaria a coluna que algo deve ser impresso na tela, e Y a linha que algo deve ser impresso na tela. Desta forma, o algoritmo abaixo:
início
 posiciona (10,2)
 escrever ‘Olá’
fim

Escreveria a palavra ‘Olá’ na segunda linha da tela, a partir da 10 coluna. Baseado nesta situação, escreva um algoritmo, utilizando este comando 'posiciona' citado, que desenhe na tela um retângulo de 60 colunas (a partir da coluna 1 da tela) e 10 linhas (a partir da linha 1 da tela), sendo que a borda deste retângulo será formada pelo caractere ‘+’. Lembre que somente a primeira e última linha deverão ter todas as colunas preenchidas com o caractere ‘+’. As demais linhas (entre 2 e 9) só terão as colunas 1 e 60 preenchidas. A aparência deste retângulo deve ser parecida com a figura abaixo: 

+++++++++++++++++++++++++++++++++++++++++
+ +
+ +
+ +
+ +
+ +
+ +
+ +
+++++++++++++++++++++++++++++++++++++++++

==============================================================

Algoritmo "Quadrado_ola"
// Disciplina   : [Linguagem e Lógica de Programação]
// Autor(a)    : Daniel Alves Barbosa
// Data atual  : 12/06/2017
Var
   // Seção de Declarações das variáveis
   coluna, linha, contador, bug3: inteiro
   mais, bug2: caractere
   posicionacol, posicionaln, posicionacol2, posicionacol3: inteiro

Inicio
   // Seção de Comandos, procedimento, funções, operadores, etc...
   mais := "+"

   repita
      escreval ("Digite a coluna  entre 2 de 59")
      leia (posicionacol)
   ate ((posicionacol>=2) e (posicionacol<=59))


   repita
      escreval ("Digite a linha entre 2 e 9")
      leia (posicionaln)
   ate ((posicionaln>=2) e (posicionaln<=9))

   //bug do 2
   se(posicionacol=2) entao
      posicionacol2:=posicionacol+1
      bug3:=1
      bug2:=""
   senao
      posicionacol2:=posicionacol-1
      bug3:=2
      bug2:=" "
   fimse
   //bug do 2

   posicionacol3:=posicionacol+3



   para linha de 1 ate 10 passo 1 faca
      //se b determinei a 1ª e 10ª linha com mais
      se ((linha=1) ou (linha=10)) entao

         para coluna de 1 ate 60 passo 1 faca
            escreva(mais)
            se (coluna = 60) entao
               escreval(" ")
            fimse
         fimpara
      senao
         //Determinei a linha que vai receber o ola
         se (linha=posicionaln) entao
            escreva (mais)
            para contador de bug3 ate posicionacol2 faca

               escreva (bug2)
               se (contador = posicionacol2) entao
                  escreva ("Ola")
                  para contador de posicionacol3 ate 59 faca
                     escreva (" ")
                     se (contador=59) entao
                        escreva (mais)
                     fimse
                  fimpara
               fimse
            fimpara

            escreval (" ")
         fimse
         //Linhas em branco
         se ((linha<>1) e (linha<>10) e (linha <> posicionaln)) entao
            para contador de 1 ate 60 faca
               se (contador=1) ou (contador=60) entao
                  escreva (mais)
               senao
                  escreva (" ")
               fimse
            fimpara
            escreval (" ")
         fimse
         //fim ultimo se
      fimse
   fimpara



Fimalgoritmo




terça-feira, 6 de junho de 2017

Divisão Algoritmo - Enquanto




algoritmo "divisao_enquanto"
// Função :
// Autor :
// Data : 31/05/2017
// Seção de Declarações
//04 - Escreva um algoritmo para ler 2 valores e se o segundo valor informado for ZERO,
//deve ser lido um novo valor, ou seja, para o segundo valor não pode ser aceito o valor
//zero e imprimir o resultado da divisão do primeiro valor lido pelo segundo valor lido.
//(utilizar a estrutura REPITA).
//05 - Reescreva o exercício anterior [04] utilizando a estrutura ENQUANTO.


var
num1, num2, divisao: real

inicio
// Seção de Comandos
  escreval("Este programa divide dois números")
  escreval("Digite o primeiro número")
  leia (num1)

     enquanto (num2=0) faca
        escreval ("Digite o segundo número")
         leia(num2)
         se(num2<>0) entao
           divisao:= num1/num2
         senao
           escreval("Não existe divisão por zero")
         fimse
    fimenquanto
    
    escreval("O resultado da divisão é ", divisao)
         

fimalgoritmo

Dividir dois números lógica de programação

04 - Escreva um algoritmo para ler 2 valores e se o segundo valor informado for ZERO, deve ser lido um novo valor, ou seja, para o segundo valor não pode ser aceito o valor zero e imprimir o resultado da divisão do primeiro valor lido pelo segundo valor lido. (utilizar a estrutura REPITA).


algoritmo "divisao"
// Função :
// Autor :
// Data : 31/05/2017
// Seção de Declarações

var
num1, num2, divisao: real

inicio
// Seção de Comandos
  escreval("Este programa divide dois números")
  escreval("Digite o primeiro número")
  leia (num1)
    repita
        escreval ("Digite o segundo número")
         leia(num2)
         se(num2<>0) entao
           divisao:= num1/num2
         senao
           escreval("Não existe divisão por zero")
         fimse
    ate(num2<>0)
    escreval("O resultado da divisão é ", divisao)
         

fimalgoritmo

Contar números pares de 1 a 100 algoritmo

algoritmo "cont_par100"
// Função :
// Autor :
// Data : 05/06/2017
// Seção de Declarações 
var
contador, soma: inteiro

inicio
// Seção de Comandos
  para contador de 1 ate 100 passo 1 faca
     se(contador mod 2 = 0) entao
     escreval (contador)
     soma := soma + contador
     fimse
  fimpara
  escreval ("A soma é ", soma)

fimalgoritmo

Cálculo de aposentadoria - Algoritmo

03 -  Uma empresa quer verificar se um empregado está qualificado para a aposentadoria ou não. Para estar em condições, um dos seguintes requisitos deve ser satisfeito:

 - Ter no mínimo 65 anos de idade.
 - Ter trabalhado no mínimo 30 anos.
 - Ter no mínimo 60 anos e ter trabalhado no mínimo 25 anos.


Com base nas informações acima, faça um algoritmo que leia: o número do empregado (código), o ano de seu nascimento e o ano de seu ingresso na empresa. O programa deverá escrever a idade e o tempo de trabalho do empregado e a mensagem 'Requerer aposentadoria' ou 'Não requerer'.

algoritmo "aposentadoria"
// Função :
// Autor :
// Data : 31/05/2017
// Seção de Declarações 

var
numero_do_empregado, ano_de_nascimento, ano_atual, ano_de_ingresso_na_empresa: inteiro
idade, tempo_de_trabalho: inteiro
tempo_que_falta: inteiro
inicio

//Ano atual
  ano_atual := 2017

// Seção de Comandos
//Entrada de dados
  escreval ("Este programa verifica o cálculo da aposentadoria")
  escreval ("-------------------------------------------------")
  escreval ("Digite o número do empregado")
  leia (numero_do_empregado)
  escreval ("Digite o ano do nascimento do empregado")
  leia (ano_de_nascimento)
  escreval ("Digite o ano de ingresso na empresa")
  leia (ano_de_ingresso_na_empresa)
//Cálculo da idade
  idade:= ano_atual - ano_de_nascimento
 //Cáculo do tempo de servico
  tempo_de_trabalho:= ano_atual - ano_de_ingresso_na_empresa
     //Condições
     se ((idade>=65) ou ((idade>=60) e (tempo_de_trabalho >=25)) ou (tempo_de_trabalho>=30)) entao
         escreval("Requerer aposentadoria")
     senao
         escreval ("Não requerer aposentadoria")
     fimse
     escreval("A idade do empregado é ", idade)
     escreval("O tempo de trabalho do emprego é ", tempo_de_trabalho)
     
     se((idade>=60) e (tempo_de_trabalho<=25)) entao
       tempo_que_falta:=25-tempo_de_trabalho
     senao
       tempo_que_falta:=30-tempo_de_trabalho
         se(tempo_que_falta<0) entao
         escreval ("O tempo que falta para se aposentar é 0 anos")
         senao
            escreval("O tempo que falta para se aposentar é: ", tempo_que_falta ," anos")
         fimse
     fimse




fimalgoritmo

Frutaria - Algoritmo

02 -  Uma fruteira está vendendo frutas com a seguinte tabela de preços:
            Até 5 Kg            Acima de 5 Kg
Morango   R$ 2,50 por Kg        R$ 2,20 por Kg
Maçã      R$ 1,80 por Kg        R$ 1,50 por Kg

Se o cliente comprar mais de 8 Kg em frutas ou o valor total da compra ultrapassar R$ 25,00, receberá ainda um desconto de 10% sobre este total. Escreva um algoritmo para ler a quantidade (em Kg) de morangos e a quantidade (em Kg) de maças adquiridas e escreva o valor a ser pago pelo cliente.

 algoritmo "frutaria06062017"
// Função :
// Autor :
// Data : 06/06/2017
// Seção de Declarações 
var
   mor_peso, maca_peso: real
   mor_preco, maca_preco: real
   frutas_pct, frutas_pst: real


inicio
// Seção de Comandos
   escreval ("Este programa calcula o preco em uma frutaria")
   escreval ("Digite o peso do morango")
   leia (mor_peso)
   escreval ("Digite o peso da macã")
   leia (maca_peso)
   
   frutas_pst:= mor_peso + maca_peso
   
   se (frutas_pst<=5 ) entao
      mor_preco:=2.50*mor_peso
      maca_preco:=1.8*maca_peso
   senao
      mor_preco:= 2.20*mor_peso
      maca_preco:= 1.50*maca_peso
   fimse
   frutas_pct:= mor_preco+maca_preco
   
   se ((frutas_pst>8) ou (frutas_pct>25)) entao
      frutas_pct:= frutas_pct*0.9
   senao
      frutas_pct:= frutas_pct*1
   fimse
   
   escreval ("O preço a ser pago é: ", frutas_pct)
   
fimalgoritmo

Idade homem mulher - algoritmo - visual g

01 - Escreva um algoritmo que leia as idades de 2 homens e de 2 mulheres (considere que as idades dos homens serão sempre diferentes entre si, bem como as das mulheres). Calcule e escreva a soma das idades do homem mais velho com a mulher mais nova, e o produto das idades do homem mais novo com a mulher mais velha.


algoritmo "idade_homem_mulher06032017"
// Função :
// Autor :
// Data : 06/06/2017
// Seção de Declarações 
var
somahv_mn, prod_hn_mv, mulher1, mulher2, homem1, homem2: inteiro
mulhern, mulherv, homemn, homemv: inteiro
inicio
// Seção de Comandos
   escreval ("Este programa compara a idade entre 4 pessoas")
   escreval ("Digite a idade da 1ª mulher")
   leia(mulher1)
   escreval ("Digite a idade da 2ª mulher")
   leia(mulher2)
   escreval ("Digite a idade do 1º homem")
   leia (homem1)
   escreval ("Digite a idade do 2º homem")
   leia (homem2)
   
   se (mulher1 < mulher2) entao
       mulhern:=mulher1
       mulherv:=mulher2
   senao
        mulherv:= mulher1
        mulhern:= mulher2
   fimse
   
   se (homem1< homem2) entao
       homemn:= homem1
       homemv:= homem2
   senao
       homemv:= homem1
       homemn:= homem2
   fimse
   
   somahv_mn:= homemv+ mulhern
   prod_hn_mv:= homemn*mulherv
   
   escreval ("A soma das idadades do homem mais novo com a mulher mais nova é ")
   escreval (somahv_mn)
   escreval ("O produto das idades do homem mais novo com a mulher mais velha é ")
   escreval (prod_hn_mv)


fimalgoritmo